Overblog Follow this blog
Administration Create my blog
Cisco & Cisco Network Hardware News and Technology

Posts with #cisco certification - ccna - ccnp - ccie tag

Show ip route command

December 25 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

Displays the entire IP route table, a summary of the routing table or route information for specific IP addresses, network masks or protocols.

Syntax: show ip route [[ipAddress [mask]] [bgp | connected | mpls [ipAddress] [ipAddress/PrefLen] [ipAddress mask] [detail] | isis | ospf | static | summary | multicast |unicast]

ipAddress

Specify an IP address for the IP routes to display.

mask

Specify an IP address mask for the specified IP address.

PrefLen

Specify a Prefix Length for the specified IP address. Valid values = 0 - 31.

Description: Use the show ip route command with no arguments to display all IP routes.

Use the show ip route command with the address argument to display routes to a specific IP address.

Use the show ip route command with the mask argument to display routes with a specific network mask.

Use the show ip route command with the bgpisisospf keyword to display summary information about all routes for the specified protocol.

Use the show ip route multicast command to display active routes used by Multicast protocols.

Use the show ip route unicast command to display active routes used for unicast forwarding.

Use the show ip route connected command to display summary information about all directly connected routes.

Use the show ip route mpls command to display all tunnel related route statistics.

use the show ip route mpls detail to display detailed information of all the tunnels by which each route/prefix is reachable. The detail keyword can optionally be used with all ipAddress variants of mpls.

Use the show ip route static command to display summary information about all statically configured routes.

Use the show ip route summary command to display summary information about all IP routes.

Factory Default: None.

Command Mode: Executive and privileged.

Example 1: In the following example, the show ip route command with no arguments displays all routes:

router>show ip route

Codes: C - connected O - OSPF i - IS-IS

S - static UD - Up/Down bit 1 L1 - level-1

B - BGP E1 - external type 1 L2 - level-2

M - MPLS E2 - external type 2

* - candidate default

m - route's metric

d - administrative distance

S * 0.0.0.0/0 via 10.200.0.1 [d:1 m:0]

S 9.9.9.9/32 via 127.0.0.1 [d:1 m:0]

C 10.200.0.0/16 directly connected to Ethernet 0

i UD 12.2.41.19/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.20/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.21/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.22/32 via 55.55.55.1 [d:115 m:35]

i UD 12.2.41.23/32 via 55.55.55.1 [d:115 m:35]

.

.

.

C 55.55.55.0/24 directly connected to GBE 1/19/2

C 55.55.55.3/32 directly connected to Null 0

S 127.0.0.0/8 via 127.0.0.1 [d:0 m:0]

C 127.0.0.1/32 directly connected to Null 0

i L1 191.191.191.191/32 via 55.55.55.1 [d:115 m:28]

i L1 191.194.1.0/24 via 55.55.55.1 [d:115 m:28]

C 193.193.193.193/32 directly connected to Loopback 0

i L1 194.10.1.0/24 via 55.55.55.1 [d:115 m:28]

C 194.10.2.0/24 directly connected to POS 1/14/2

C 194.10.2.1/32 directly connected to POS 1/14/2

C 194.10.2.2/32 directly connected to Null 0

S 200.1.1.0/24 via 127.0.0.1 [d:1 m:0]

S 200.1.2.0/24 via 127.0.0.1 [d:1 m:0]

S 200.1.3.0/24 via 127.0.0.1 [d:1 m:0]

.

.

.

The following table describes the fields displayed by the show ip route command.

Table 1-8. Fields Displayed by show ip route 

Field

Description

connected

Specifies the route was learned as a result of configuring the interface.

static

Specifies the route was explicitly configured using the ip route command.

BGP

Specifies the route was received from BGP protocol advertisements.

MPLS

Specifies this route carries MPLS data.

external type 1

Specifies the route was imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, this route used the cost associated with the link between the ASBR and this router as part of the cost of the route.

external type 2

Specifies the route was imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, this route does not use the cost associated with the link between the ASBR and this router as part of the cost of the route.

isis

Specifies this route was received from IS-IS protocol advertisements.

N.N.N.N/nn

Network address and mask of the remote network.

via N.N.N.N

Indicates the next router in the remote network.

directly connected to

Indicates the network is directly connected to a local interface.

UD

Indicates the Up/Down bit is set and that the route was leaked from L2 into L1.

d:

The administrative distance assigned to this route.

m:

The metric assigned to this route.

Example 2: In the following example, the show ip route static command displays information about statically configured routes:

router>show ip route static

S 0.0.0.0/0 via 10.5.0.1 [w:1 m:0]

S 127.0.0.0/8 via 127.0.0.1 [w:0 m:0]

S 131.1.1.0/24 via 127.0.0.1 [w:1 m:0]

S 131.1.2.0/24 via 127.0.0.1 [w:1 m:0]

S 131.1.3.0/24 via 127.0.0.1 [w:1 m:0]

S 131.1.4.0/24 via 127.0.0.1 [w:1 m:0]

Example 3: In the following example, the show ip route summary command displays summary information about all IP routes:

router#show ip route summary 



Route source Networks

connected 12

static 2

bgp 100654

ospf intra-area 1785

total 102453 

The following table defines the fields displayed in the show ip route summary command:

Table 1-9. Fields Displayed by show ip route summary 

Field

Description

connected

These routes were learned as a result of configuring the interface

kernel

These routes were in the kernel before the routing task started running.

static

The number of routes that were explicitly configured using the ip route command.

bgp

The number of routes received from BGP protocol advertisements.

ospf intra-area

The number of routes learned from within this area.

ospf inter-area

The number of routes received from other OSPF areas.

ospf external-1

These routes were imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, these routes use the cost associated with the link between the ASBR and this router as part of the cost of the route.

ospf external-2

These routes were imported into the OSPF area from an Autonomous System Boundary Router (ASBR). Further, these routes do not use the cost associated with the link between the ASBR and this router as part of the cost of the route.

isis

The number of routes received from IS-IS protocol advertisements.

total

The total number of routes in the IP route table.

Refer to http://www.powerfast.net

More Related Cisco IOS Command Topics:

Show memory Command

Show module command

Show controllers command

Show interfaces

Show running-config

Cisco Show Version Command

Top 10 Commands Every Cisco IOS User Should Know

Configure logging in Cisco IOS

Read more

Show logging

December 11 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

Use the show logging EXEC command to display the state of logging (syslog).

show logging [history]

Syntax Description: history (Optional) Display information in the syslog history table only.

Command Mode: EXEC

Usage Guidelines

This command first appeared in Cisco IOS Release 10.0.

This command displays the state of syslog error and event logging, including host addresses, and whether console logging is enabled. This command also displays Simple Network Management Protocol (SNMP) configuration parameters and protocol activity.

When you use the optional history keyword, information about the syslog history table is displayed such as the table size, the status of messages, and text of messages stored in the table. Messages stored in the table are governed by the logging history global configuration command.

Sample Display

The following is sample output from the show logging command:

Router# show logging

Syslog logging: enabled

     Console logging: disabled

     Monitor logging: level debugging, 266 messages logged.

     Trap logging: level informational, 266 messages logged.

     Logging to 192.180.2.238

SNMP logging: disabled, retransmission after 30 seconds

    0 messages logged

 

The following table describes significant fields shown in the display.

Field

Description

Syslog logging

When enabled, system logging messages are sent to a UNIX host that acts as a syslog server; that is, it captures and saves the messages.

Console logging

If enabled, states the level; otherwise, this field displays disabled.

Monitor logging

Minimum level of severity required for a log message to be sent to a monitor terminal (not the console).

Trap logging

Minimum level of severity required for a log message to be sent to a syslog server.

SNMP logging

Shows whether SNMP logging is enabled and the number of messages logged, and the retransmission interval.

The following is sample output from the show logging history command:

Router# show logging history

Syslog History Table: 1 maximum table entry, saving level notifications or higher

0 messages ignored, 0 dropped, 15 table entries flushed,

SNMP notifications not enabled

  entry number 16: SYS-5-CONFIG_I

  Configured from console by console

  timestamp: 1110

 

The following table describes the significant fields shown in the display.

Field

Description

maximum table entry

Number of messages that can be stored in the history table. Set with the logging history size command.

saving level notifications or higher

Level of messages that are stored in the history table and sent to the SNMP server (if SNMP notification is enabled). Set with the logging history command.

messages ignored

Number of messages not stored in the history table because the severity level is greater than that specified with the logging history command.

dropped

Number of messages that could not be processed due to lack of system resources. Dropped messages do not appear in the history table and are not sent to the SNMP server.

table entries flushed

Number of messages that have been removed from the history table to make room for newer messages.

SNMP notifications

Whether syslog traps of the appropriate level are sent to the SNMP server. Syslog traps are either enabled or not enabled through the snmp-server enable command.

entry number

Number of the message entry in the history table.

SYS-5-CONFIG_I
Configured from console by console

Cisco IOS syslog message consisting of the facility name (SYS) which indicates where the message came from, the severity level (5), the message name (CONFIG_I), and the message text.

timestamp

Time, based on the router's up time, that the message was generated.

More Related Cisco IOS Commands Reviews:

Show controllers command

Show interfaces

Show running-config

Cisco Show Version Command

Top 10 Commands Every Cisco IOS User Should Know

Configure logging in Cisco IOS

Read more

Which Cisco Exam of CCENT and CCNA Certification Should You Take 2013?

April 22 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

If you are considering taking the exams to become certified as a Cisco Certified Entry Networking Technician (CCENT) or Cisco Certified Network Associate (CCNA), this article by Cisco expert Michelle Plumb will help you decide which exams you should take. These exams are not for the faint at heart. They are meant to weed out those who are committed from those who are easily dissuaded.

 

For more information on the new Cisco CCENT/CCNA exams, including special offers and study guides, visit our Cisco Press "About CCNA" page.

 

This article reviews the options you have when preparing for the Cisco Certified Entry Networking Technician (CCENT) certification and Cisco Certified Network Associate (CCNA) certification.

 

CCENT

First, let’s start with the CCENT certification. This certification is geared toward an entry-level network technician. This certification proves you have foundational knowledge for a small-to medium-sized network. Passing this exam is the first step to enter into a network engineering job using Cisco routers and switches. The course that you should take for the CCENT exam is ICND1v2.0. This is an updated course and exam due this spring. The new exam number is 100-101. Once you have passed this exam, you become a CCENT.

 

Note:

The ICND (Interconnecting Cisco Network Devices) exams are very challenging. You need to make sure you know all the material extremely well. The exam is timed, and these exams could run close on time. Know these tips before taking the test:

  • I would know subnetting extremely well. You cannot afford to spend too much time solving the troubleshooting questions on IPv4 subnetting.
  • You do not have access to a calculator.
  • You may also run into simulations that require knowledge to configure routing protocols and the appropriate IPv4 addresses. New to this course is IPv6 configuration, and you will need to be able to use IPv6 addresses appropriately as well as configuration options with routing protocols.
  • The exams could include multiple choice, drag and drop, as well as simulations.

 

Cisco’s website does have practice questions so you are familiar with the exam interface.

 

CCNA

If you have taken the ICND1 course and exam, strongly consider taking the ICND2 course and exam 200-101 as well. By taking this second exam and passing it, you will achieve the CCNA certification. The CCNA credentials show your abilities to install, configure, operate, and troubleshoot medium-sized routed and switched networks.

 

This exam is also challenging. Again, as with the CCENT exam, make sure you feel extremely comfortable with all the material covered in the ICND courses. You can expect the same type of questions using simulators, drag and drop, as well as multiple choices.

 

A Combination

You do have another option for exams. If you are a very skilled individual who has in-depth knowledge and experience configuring routers and switches in a medium- to large-sized network, then the combination exam might be for you. Cisco has an exam that covers knowledge from both ICND1 and ICND2: exam 200-120.

 

I highly caution anybody who is considering taking the all-in-one exam. This is a very tough exam. You need to make sure you know subnetting like the back of your hand and can do it very quickly. You also may see several simulations where you need to configure the various routing protocols, including figuring out what subnet information needs to be entered. With the new ICNDv2.0 classes and exams, you also have to be very proficient with IPv6. You will need to be capable of configuring and routing IPv4 and IPv6 at the same time. You may also see drag and drop type questions.

 

Scheduling

You will schedule these exams on the Pearson Vue website. You will need to bring a picture ID, and a photo will be taken of you at the testing center. You will also need to sign some paperwork about the exams, and sign in and out of the exam center.

 

Study Tips

If this is the first exam you have taken in a while, I have some study tips that have helped me:

  • Make sure to attend the appropriate course and/or purchase the official Cisco press books for the exam.
  • Review the material at least three times. Then use practice questions to see how I am doing with the material. For these exams, as stated earlier in this article, you have to know subnetting. So when I was just learning how to subnet, I made sure every day I ran through a subnetting problem, just to keep it fresh in my mind.
  • Do not wait longer than one month from finishing the class until taking the exam. We start to lose some of the information that is fresh in our minds.
  • Get a good night’s sleep the night before the exam. A good solid breakfast or lunch before the exam is a good idea as well.
  • Stop studying the day before. If you don’t know it by then, you might want to think about rescheduling the exam. You only have 24 hours before your scheduled time to make any changes. But make sure you double-check the cancelation policy.
  • Make sure to know exactly how long it will take to reach the exam center, and arrive 15 minutes early. Sometimes if no one is in the seat you are scheduled for, the test center might let you get started a little early if it is available.
  • Be prepared to store your accessories or valuables. You will be required to lock your valuables in a locker. You are not allowed to take purses, cell phones, etc. into the room where the exam is administered. You might also be asked to leave your watch in a locked locker.
  • When you get into the testing room, you will be given something to write with either a dry erase type board or paper. You will have to return these materials when you are done with the exam.

 

The Exam Process

Once you sit down and start into the exam process, you will see examples of the type of questions and how to navigate them. This does not take away from your timed exam. If you are not familiar with the types of questions and how to navigate the simulations, the examples will walk you through how to navigate them. You may also receive a brief questionnaire about your training before starting the official exam.

 

Once you are finished with this portion of the exam, the real exam begins. Try to take a deep breath and stay calm. I still get nervous to this day after taking many of these exams every year. Make sure you read each question thoroughly. This is one of the biggest reasons people miss questions. Read the entire question and all the answers before you start to formulate an answer. For simulations, double-check your work before you submit and move on. With Cisco exams, you cannot go back to a question once you have clicked Next to move to the next question.

 

When you have finished, you will see your score, and a printout of the exam information will be given to you by the exam proctor.

 

Final Thoughts

If something happens and you don’t pass on the first attempt, please don’t give up. These exams are very difficult, and I don’t want to see anyone get discouraged from trying again.

 

---Article resource from http://www.pearsonitcertification.com/articles/article.aspx?p=2036575

 

More Reviews about Cisco Exam:

CCNP SWITCH 642-813 Guide: Configuring IP SLA

Cisco CCNP: How to Configure IP Source Guard?

CCNP TSHOOT: Cisco Troubleshooting Techniques & Procedures

How to Prepare for the CCIE Voice Written Exam?

Guide to Cisco CCNA Voice Exam 640-461…Reviews, Main Topics

Top 5 VoIP Concepts to Know for CCNA Voice—VoIP Basic for CCNA Voice Exam

Top Cisco Certification Books

Read more

Basic Questions to Prepare Cisco CCNA

March 11 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

Here you will find answers to CCNA – Basic Questions

Question 1

For which type of connection should a straight-through cable be used?

A. switch to switch

B. switch to hub

C. switch to router

D. hub to hub

E. router to PC

Answer: C

Explanation

To specify when we use crossover cable or straight-through cable, we should remember:

Group 1: Router, Host, Server

Group 2: Hub, Switch

One device in group 1 + One device in group 2: use straight-through cable

Two devices in the same group: use crossover cable

In this case we can use straight-through cable to connect a switch to a router -> C is correct.

 

Question 2

Which type of cable is used to connect the COM port of a host to the COM port of a router or switch?

A. crossover

B. straight-through

C. rolled

D. shielded twisted-pair

Answer: C

Explanation

The correct question should be “Which type of cable is used to connect the COM port of a host to the CONSOLE port of a router or switch?” and the correct answer is rollover cable. But we can’t plug this rollover cable directly into our host because it will not work. We often use a RJ45 to DB9 Female cable converter as shown below:

Basic-Questions-to-Prepare-Cisco-CCNA01.jpg

Question 3

What is the first 24 bits in a MAC address called?

A. NIC

B. BIA

C. OUI

D. VAI

Answer: C

Explanation

Organizational Unique Identifier (OUI) is the first 24 bits of a MAC address for a network device, which indicates the specific vendor for that device as assigned by the Institute of Electrical and Electronics Engineers, Incorporated (IEEE). This identifier uniquely identifies a vendor, manufacturer, or an organization.

 

Question 4

In an Ethernet network, under what two scenarios can devices transmit? (Choose two)

A. when they receive a special token

B. when there is a carrier

C. when they detect no other devices are sending

D. when the medium is idle

E. when the server grants access

Answer: C D

Explanation

Ethernet network is a shared environment so all devices have the right to access to the medium. If more than one device transmits simultaneously, the signals collide and cannot reach the destination.

If a device detects another device is sending, it will wait for a specified amount of time before attempting to transmit.

When there is no traffic detected, a device will transmit its message. While this transmission is occurring, the device continues to listen for traffic or collisions on the LAN. After the message is sent, the device returns to its default listening mode.

So we can see C and D are the correct answers. But in fact “answer C – when they detect no other devices are sending” and “when the medium is idle” are nearly the same.

 

Question 5

Which two benefits are provided by using a hierarchical addressing network addressing scheme? (Choose two)

A. reduces routing table entries

B. auto-negotiation of media rates

C. efficient utilization of MAC addresses

D. dedicated communications between devices

E. ease of management and troubleshooting

Answer: A E 

 

Question 6

When a host transmits data across a network to another host, which process does the data go through?

A. standardization

B. conversion

C. encapsulation

D. synchronization

Answer: C

Explanation

To transmit to another host, a host must go through the TCP/IP model (very similar to the OSI model). At each layer, the message is encapsulated with that layer’s header (and trailer if it has). This process is called encapsulation.

 

Question 7

Which two Ethernet fiber-optic modes support distances of greater than 550 meters?

A. 1000BASE-CX

B. 100BASE-FX

C. 1000BASE-LX

D. 1000BASE-SX

E. 1000BASE-ZX 

Answer: C E

Explanation

Below lists the cabling standards mentioned above

 

Standard

Cabling

Maximum length

1000BASE-CX

Twinaxial cabling

25 meters

100BASE-FX

Two strands, multimode

400 m

1000BASE-LX

Long-wavelength laser, MM orSM fiber

10 km (SM)3 km (MM)

1000BASE-SX

Short-wavelength laser, MM fiber

220 m with 62.5-micron fiber; 550 mwith 50-micron fiber

1000BASE-ZX

Extended wavelength, SM fiber

100 km

 

Note:

MM: Multimode

SM: Single-mode

(Reference: The official self-study test preparation guide to the Cisco CCNA INTRO exam 640-821)

 

Question 8

Refer to the exhibit. What type of connection would be supported by the cable diagram shown?

 

Pin

Color

Function

Pin

Color

Function

1

White/Green

TX+

1

White/Green

TX+

2

Green

TX-

2

Green

TX-

3

White/Orange

RX+

3

White/Orange

RX+

6

Orange

RX-

6

Orange

RX-

 

A. PC to router

B. PC to switch

C. server to router

D. router to router

Answer: B

Explanation

From the “Pin” and “Color” in the exhibit we know that this is a straight-through cable so it can be used to connect PC to switch.

 

Question 9

Refer to the exhibit. What type of connection would be supported by the cable diagram shown?

 

Pin 

Color 

Function

Pin

Color

Function

1

White/Green

TX+

3

White/Green

RX+

2

Green

TX-

6

Green

RX-

3

White/Orange

RX+

1

White/Orange

TX+

6

Orange

RX-

2

Orange

TX-

 

A. PC to router

B. PC to switch

C. server to switch

D. switch to router

Answer: A

Explanation

This is a crossover cable so it can be used to connect PC and router.

Basic-Questions-to-Prepare-Cisco-CCNA02.jpg

 

Question 10

Which two topologies are using the correct type of twisted-pair cables? (Choose two)

A. using-the-correct-type-of-twisted-pair-cables01.jpg

B. using-the-correct-type-of-twisted-pair-cables02.jpg

C. using-the-correct-type-of-twisted-pair-cables03.jpg

D. using-the-correct-type-of-twisted-pair-cables04.jpg

E. using-the-correct-type-of-twisted-pair-cables05.jpg

Answer: D E

More Related Cisco CCNA Tips:

Core Topics Covered on the CCNA Exam

Tutorial for CCNA Certification: Talking About Switch Port Security

Best Path for Getting Your CCNA Certification

10 Things to Know About the Cisco CCNA Voice Certification

Cisco Routing Quiz for Preparing CCNA Exam

Guide to Cisco CCNA Voice Exam 640-461…Reviews, Main Topics

Top 5 VoIP Concepts to Know for CCNA Voice—VoIP Basic for CCNA Voice Exam

Read more

Cisco CCNA Tips–Answers to Protocols & Services Questions

February 28 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

Here we will offer some Cisco CCNA Tips–Protocols & Services Questions with Answers and Explanations

Question 1

An administrator attempts a traceroute but receives a “Destination Unreachable” message. Which protocol is responsible for that message?

A. RARP 
B. RUDP 
C. ICMP 
D. SNMP

Answer: C

Explanation

The ICMP destination unreachable message is generated by a router (which is reachable) to inform the source host that the destination unicast address is unreachable.

 

Question 2

DNS servers provide what service?

A. They run a spell check on host names to ensure accurate routing 
B. They convert domain names into IP address 
C. Given an IP address.they determine the name of the host that is sought 
D. They map individual hosts to their specific IP addresses

Answer: B

Explanation

For example, when you open a web browser (IE, Firefox…) and type a domain (like google.com). This domain will be sent to a DNS server. The DNS server looks up this domain in its database and sends back a corresponding IP address which you can use to access that website.

Note: A DNS server can be a dedicated device for DNS service or integrated into a networking device (like router).

 

Question 3

Which of the following protocols uses both TCP and UDP ports?

A. SMTP 
B. Telnet 
C. FTP
D. DNS 

Answer: D

Explanation

DNS can use either the User Datagram Protocol (UDP) or Transmission Control Protocol (TCP) with a destination port of 53.

Note:

Simple Mail Transfer Protocol (SMTP) is specified for mail transport and uses TCP port 25.
Telnet uses TCP on port 23.
File Transfer Protocol (FTP) uses TCP on port 20, 21.
Trivial File Transfer Protocol (TFTP) uses UDP on port 69.
HTTP Secure (HTTPS) uses TCP on port 443.

 

Question 4

Which protocol should be used to establish a secure terminal connection to a remote network device?

A. ARP 
B. SSH
C. Telnet
D. WEP
E. SNMPv1
F. SNMPv2

Answer: B

Explanation

Secure Shell (SSH) protocols secure terminal session data across insecure environments such as the internet.

 

Question 5

A network administrator issues the ping 192.168.2.5 command and successfully tests connectivity to a host that has been newly connected to the network. Which protocols were used during the test? (Choose two)

A. ARP
B. CDP
C. DHCP
D. DNS
E. ICMP

Answer: A E

Explanation

In this question we are not sure the host 192.168.2.5 is in or outside the local network. But in both cases the ARP protocol are used to get the MAC address:

If host 192.168.2.5 is inside the local network, our device will broadcast an ARP Request to ask the MAC address of the host 192.168.2.5 (something like “If your IP is 192.168.2.5, please send me your MAC address”).
If host 192.168.2.5 is outside the local network, our device will broadcast an ARP Request to ask the MAC address of the local port (the port in the same subnet with our device) of the default gateway. Notice that the IP of the default gateway has been already configured in our device.

-> In both cases, our device must broadcast an ARP Request -> A is correct.

After getting the ARP of the destination device, our device will use ICMP protocol to send the “ping” -> E is correct.

Note: The question states “the host has been newly connected to the network” which means our device hasn’t had the MAC address of this host in its ARP table -> it needs to send ARP Request.

There is one situation which makes answer A incorrect: the newly connected host is outside the network but our device has already learned the MAC address of the default gateway -> in this case no ARP Request will be sent. So I assume the question wants to imply the newly connected host is in the local network.

 

Question 6

Which network protocol does DNS use?

A. FTP 
B. TFTP 
C. TCP 
D. UDP
E. SCP

Answer: D

Explanation

It is funny that in Question 3 I answered “DNS uses both TCP & UDP” but in this question we can only choose one answer and it should be “DNS uses UDP”. So I wish to explain more:

Normally a client sends a DNS Query using UDP Protocol over Port 53. If it does not get response from a DNS Server, it must re-transmit the DNS Query using TCP after 3-5 seconds. So we can say DNS prefers using UDP to TCP -> the answer should be UDP.

 

Question 7

When two hosts are trying to communicate across a network, how does the host originating the communication determine the hardware address of the host that it wants to “talk” to?

A. RARP request
B. Show Network Address request
C. Proxy ARP request
D. ARP request
E. Show Hardware Address request

Answer: D

Explanation

The address resolution protocol (ARP) is a protocol used to map IP network addresses to the hardware addresses.

If the destination host is inside the local network, the originating host will broadcast an ARP Request to ask the MAC address of that host.
If the destination host is outside the local network, the originating host will broadcast an ARP Request to ask the MAC address of the local port (the port in the same subnet with our device) of the default gateway. Notice that the IP of the default gateway has been already configured in our device.

 

Question 8

Refer to the exhibit, Host A pings interface S0/0 on router 3, what is the TTL value for that ping?

Question-8.jpg

A. 253
B. 252 
C. 255 
D. 254

Answer: A

Explanation

From the CCNA ICND2 Exam book: “Routers decrement the TTL by 1 every time they forward a packet; if a router decrements the TTL to 0, it throws away the packet. This prevents packets from rotating forever.” I want to make it clear that before the router forwards a packet, the TTL is still remain the same. For example in the topology above, pings to S0/1 and S0/0 of Router 2 have the same TTL.

The picture below shows TTL values for each interface of each router and for Host B. Notice that Host A initializes ICMP packet with a TTL of 255:

Question-802.jpg

More Topics Related to Networking Protocols:

BGP Routing Protocol Tips You Need to Know

Routing Information Protocol & RIP Configuration

How to Configure IGRP (Interior Gateway Routing Protocol)?

How to Configure Basic NAT with Overloading?

10 Things to Know About the Cisco CCNA Voice Certification

Read more

How to Configure IGRP?

February 6 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

If you are not familiar with Interior Gateway Routing Protocol (IGRP), click the following link to view an introduction to Interior Gateway Routing Protocol (IGRP).

 

Interior Gateway Routing Protocol (IGRP) Configuration

Interior Gateway Routing Protocol (IGRP) can be configured in a router using the following IOS commands. If you have a new router with a latest IOS release, you may not find Interior Gateway Routing Protocol (IGRP) configuration commands because Interior Gateway Routing Protocol (IGRP) is removed from new IOS releases.

Router(config)# router igrp ASN
Router(config-router)# network Network_ID

 

ASN in the above IOS command stands for Autonomous System Number.

 

Interior Gateway Routing Protocol (IGRP) - Lab Practice

The following diagram shows our lab setup. We have three routers, three switches and three hosts connected as below. The host names, IP addresses and the interfaces of the routers are shown in diagram. The IP addresses of the hosts are also shown in the diagram.

Interior-Gateway-Routing-Protocol--IGRP--Lab-Practice.jpg

Hostname and IP address configuration in Router01

Connect to Router01 console and use the following IOS commands to configure host name as Router01.

Router>enable
Router#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#

 

Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router01 and configure IP address as 172.16.0.1/16.

Router01>enable 
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/0 configuration mode on Router01 and configure IP address as 172.17.0.1/16. You have to set a clock rate also using the "clock rate" command on S0/0 interface, since this is the DCE side.

Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Hostname and IP address configuration in Router02

Connect to Router02 console and use the following IOS commands to configure host name as Router02.

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#

 

Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router02 and configure IP address as 172.18.0.1/16.

Router02>enable 
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/0 configuration mode on Router02 and configure IP address as 172.17.0.2/16.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/1 configuration mode on Router02 and configure IP address as 172.19.0.1/16. You have to set a clock rate also using the "clock rate" command on S0/1 interface, since this is the DCE side.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Hostname and IP address configuration in Router03

Connect to Router03 console and use the following IOS commands to configure host name as Router03.

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#

 

Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router03 and configure IP address as 172.20.0.1/16.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/1 configuration mode on Router03 and configure IP address as 172.19.0.2/16.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Interior Gateway Routing Protocol (IGRP) configuration in Router01

Connect to Router01 console and use the following IOS commands to configure Interior Gateway Routing Protocol (IGRP) in Router01. Please refer the beginning of this lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS command.

 

In the IOS "network" command, shown below, we specify only the directly connected networks of this router.

Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)# router igrp 1
Router01(config-router)# network 172.16.0.0
Router01(config-router)# network 172.17.0.0
Router01(config-router)#exit
Router01(config)#exit
Router01#

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Interior Gateway Routing Protocol (IGRP) configuration in Router02

Connect to Router02 console and use the following IOS commands to configure Interior Gateway Routing Protocol (IGRP) in Router02. Please refer the beginning of this lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS command.

 

In the IOS "network" command, shown below, we specify only the directly connected networks of this router.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)# router igrp 1
Router02(config-router)# network 172.17.0.0
Router02(config-router)# network 172.18.0.0
Router02(config-router)# network 172.19.0.0
Router02(config-router)#exit
Router02(config)#exit
Router02#

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Interior Gateway Routing Protocol (IGRP) configuration in Router03

Connect to Router03 console and use the following IOS commands to configure Interior Gateway Routing Protocol (IGRP) in Router03. Please refer the beginning of this lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS command.

 

In the IOS "network" command, shown below, we specify only the directly connected networks of this router.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)# router igrp 1
Router03(config-router)# network 172.19.0.0
Router03(config-router)# network 172.20.0.0
Router03(config-router)#exit
Router03(config)#exit
Router03#

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

How to View the Routing Table in Router01

After the network is converged after the initial configuration and Interior Gateway Routing Protocol (IGRP) configuration, we can use the "show ip route" to view the routing table in Router01, as shown below.

Router01>enable
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
I 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
I 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
I 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0

 

The "I" character at the beginning of a line in routing table shows that it is a route discovered byInterior Gateway Routing Protocol (IGRP) and "C" character shows that it is a directly connected network.

 

How to View the Routing Table in Router02?

When the network is converged after the initial configuration and Interior Gateway Routing Protocol (IGRP) configuration, we can use the "show ip route" to view the routing table in Router02, as shown below.

Router02>enable
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

I 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
I 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1

 

The "I" character at the beginning of a line in routing table shows that it is a route discovered by Interior Gateway Routing Protocol (IGRP) and "C" character shows that it is a directly connected network.

 

How to View the Routing Table in Router03?

When the network is converged after the initial configuration and Interior Gateway Routing Protocol (IGRP) configuration, we can use the "show ip route" to view the routing table in Router03, as shown below.

Router03>enable
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

I 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1
I 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
I 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0

 

The "I" character at the beginning of a line in routing table shows that it is a route discovered by Interior Gateway Routing Protocol (IGRP) and "C" character shows that it is a directly connected network.

 

Verify the Connectivity between Networks Using the Ping Command

To verify the Interior Gateway Routing Protocol (IGRP) routes and the connectivity between networks, run the ping command from Host01 (IP address: 172.16.0.10/16) to Host03 (IP address: 172.20.0.10/16).

C:\>ping 172.20.0.10

Pinging 172.20.0.10 with 32 bytes of data:

Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125

Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms

 

The ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Interior Gateway Routing Protocol (IGRP) is configured well in three routers and there is network connectivity between different networks.

---Reference from http://www.omnisecu.com/cisco-certified-network-associate-ccna/how-to-configure-interior-gateway-routing-protocol-igrp.htm

More Related Topics:

Routing Information Protocol & RIP Configuration

How to Configure IGRP (Interior Gateway Routing Protocol)?

Basic Information of Configuring HSRP on a Cisco Router

How to Configure Cisco IP SLA?

What the Main Difference between HSRP, VRRP and GLBP Protocols

Read more

IGRP Basic Information

February 2 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

The Interior Gateway Routing Protocol (IGRP) is a Cisco-proprietary routing protocol for IP

.IGRP-Info.jpg

Some of the features ifInterior Gateway Routing Protocol (IGRP) are

• Interior Gateway Routing Protocol (IGRP) uses a sophisticated metric based on bandwidth and delay.

• Interior Gateway Routing Protocol (IGRP) uses triggered updates to speed-up convergence.

• Interior Gateway Routing Protocol (IGRP) supports unequal-cost load balancing to a single destination.

 

Interior Gateway Routing Protocol (IGRP) uses bandwidth, delay, reliability, load, to find the metric value. By default, the algorithm uses only bandwidth and delay, but the other metric components can be enabled. IGRP uses bandwidth, delay, reliability, load, and MTU to find the metric value. By default, the algorithm uses only bandwidth and delay, but the other metric components can be enabled.

The following formula is used to calculate the composite metric of IGRP.

Metric = [K1 * Bandwidth + (K2 * Bandwidth)/ (256-Load) + K3*Delay] * [K5/(Reliability + K4)]

The default constant values are K1 = K3 = 1 and K2 = K4 = K5 = 0.

If K5 = 0, the [K5/ (reliability + K4)] term is not used. So, given the default values for K1 through K5, the composite metric calculation used by IGRP reduces to Metric = Bandwidth + Delay.

•To find the bandwidth value, find the smallest of all the bandwidths in Kbps from outgoing interfaces anddivide 10,000,000 by that number.

•Reliability and load are measured 1–255. A reliability of 1 is least reliable, while 255 is most reliable. A load of 1 is least utilized, while 255 is 100 percent utilized. The MTU refers to the size of the frame. If a route has lower metric value, then that route is preferred.

•In order to find the delay, add all of the delays (in microseconds) from the outgoing interfaces and divide thisnumber by 10. (The delay is in tenths of microseconds.)

 

More Related Topics:

How to Configure IGRP (Interior Gateway Routing Protocol)?

Routing Information Protocol & RIP Configuration

How to Configure EIGRP on a Cisco Router?

How to Configure OSPF on Cisco Routers?

OSPF, How to Configure OSPF in the Cisco IOS?

How to Configure OSPF in a Single Area?

How to Troubleshoot OSPF?

Read more

Basic Information of RIP (Routing Information Protocol)

January 31 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

IP RIP (Routing Information Protocol) comes in two different versions: 1 and 2. Version 1 is a distance vector protocol (RFC 1058) and Version 2 is a hybrid protocol (RFCs 1721 and 1722).

Routing-Information-Protocol--RIP-.jpg

Routing Information Protocol Version 1 (RIPv1)

RIPv1 uses local broadcasts to share routing information. These updates are periodic in nature, occurring, by default, every 30 seconds. To prevent packets from circling around a loop forever, both versions of RIP solve counting to infinity by placing a hop count limit of 15 hops on packets. Any packet that reaches the sixteenth hop will be dropped. RIPv1 is a classful protocol. RIP supports up to six equal-cost paths to a singledestination. Equal-cost path are the paths where the metric is same (Hop count).

 

Routing Information Protocol (RIPv2)

RIPv2 is a distance vector protocol with routing enhancements built into it, and it is based on RIPV1. Therefore, it is commonly called a hybrid protocol.

 

RIPv2 uses multicasts instead of broadcasts. RIPv2 supports triggered updates. when a change occurs, a RIPv2 router will immediately propagate its routing information to its connected neighbours. RIPv2 is a classless protocol and it supports variable-length subnet masking (VLSM).

Both RIPv1 and RIPv2 uses hop count as the metric.

Differences between RIPv1 and RIPv2

RIPv1

• Supports only classful routing (Does not support VLSM).

• No authentication.

• RIPv1 uses Broadcast.

RIPv2

•Supports classless routing (Supports VLSM).

RIPv2 incorporates the addition of the network mask in the update to allow classless routing advertisements.

• Authentication is available.

• RIPv2 uses multi-cast instead of broadcast. Multicast communication reduces the burden on the network devices that do not need to listen to RIP updates.

 

More Related Tips:

Routing Information Protocol & RIP Configuration

Read more

Best Cisco CCNA Books for Your CCNA Study

January 8 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

Recommended-Cisco-CCNA-Books01.jpg

Well the first book we would have to recommend would be non-other than the Cisco Press Official CCNA Certification Library which includes the ICND1 and ICND2 Official certification guides. This is a must have for every candidate that is perusing the CCNA and it is highly recommended that every candidate reads these books prior to attempting to do any labs provided by the Free CCNA Workbook.

 

Recommended-Cisco-CCNA-Books02.jpg
When I started getting into Cisco Networking back in 2004, one of the books I read at the time was Tom Lammel’s CCNA book, this guy writes his books in such a way that they are easy to understand and less confusing than that of the Cisco Press Official Certification Library. Detailed explanations and an easy to follow page structure.

Recommended-Cisco-CCNA-Books03.jpg

说明: http://www.assoc-amazon.com/e/ir?t=a11917-453-20&l=as2&o=1&a=0789737140
If you are looking for CCNA practice exam questions than look no further. This book written by none other than the legendary Jeremy Cioara. This book is all about practice questions. Hundreds of questions with answers and explanations. Highly recommended to test your knowledge and readiness for the CCNA Exam.

 

More Related Reading:

Top Cisco Certification Books

Core Topics Covered on the CCNA Exam

Best Path for Getting Your CCNA Certification

10 Questions Help You Prepare CCNA 640-802 Exam

Read more

Frame Relay Switch Configuration-CCNA Certification Training

August 27 2012 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

A Cisco Lab Case Study---Many CCNA certification candidates want to add a frame relay switch to their Cisco router lab, but aren't quite sure how to configure one.

 

Other candidates aren't quite sure what frames relay switch is, or what Cisco routers can serve as such a switch. This CCNA case study will examine how to add one of these pivotal devices to a Cisco lab.

 

A Cisco lab's frame relay switch is not a switch at all; it's a Cisco router. Almost any Cisco router can serve as your frame switch, but you will need multiple serial interfaces to make a router particularly effective in this role.

 

I recommend you get a Cisco router with at least four serial interfaces. Cisco 2520s makes excellent frame switches, and by doing a search on eBay for "frame relay switch", you'll quickly find several others that can as well.

 

The frame relay switch is going to play the role of the frame provider in your lab. In essence, you've got a one-switch frame relay cloud, which gives you a tremendous opportunity to practice frame relay scenarios.

 

In this example, I've got three Cisco routers that are going to be the production routers in my lab - R1, R2, and R3. I have a fourth router that will serve as the frame relay switch. The DLCI assignments I've come up with are as follows:

  • R1 is the hub and will use DLCI 122 to reach R2, DLCI 123 to reach R3.
  • R2 is a spoke router and will use DLCI 221 to reach both R1 and R3.
  • R3 is a spoke router and will use DLCI 321 to reach both R1 and R2.

 

The physical connections are as follows. All connections are using DTE/DCE cables with the DCE end of the cable connected to the frame relay switch.

  • R1 is connected to the frame switch's Serial1 port.
  • R2 is connected to the frame switch's Serial2 port.
  • R3 is connected to the frame switch's Serial3 port.

 

On the frame switch, the global command frame-relay switching is required to make the router act as a frame relay switch. Let's take a look at the commands we'll need on the frame switch's Serial1 port, which is connected to R1.

interface Serial1
 no ip address
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clockrate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 122 interface Serial2 221
 frame-relay route 123 interface Serial3 321

Note that there is no IP address on the port, and frame relay encapsulation is enabled. The clockrate command is necessary on the DCE end of the connection, so you see it here.

 

You also see that the interface is hard-coded as a DCE with theframe-relay intf-type dce command. Not all current IOS versions require this; just make sure you have the DCE end of the cable attached to the frame switch and verify that with show controller serial x.

 

Finally, we come to the frame-relay route command. The syntax seems a little tricky, but once you break it down it's pretty simple.

  • frame-relay route 122 = the incoming DLCI
  • interface serial2 = data coming in on DLCI 122 is sent out this port
  • 221 = data sent out interface serial2 will use this DLCI

 

Getting those statements correct is the hardest part of configuring your frame relay switch. The good part is that once you have your frame switch configured and working properly, you can just leave the configuration there.

 

We'll take a look at how to verify your frame switch configuration in just a moment, but first, let's review the important section of the frame switch configuration we've talked about here.

hostname FRAME_SWITCH
!
!
ip subnet-zero
no ip domain-lookup
frame-relay switching
!
!
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address

interface Serial1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clockrate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 122 interface Serial2 221
 frame-relay route 123 interface Serial3 321

!
interface Serial2
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clockrate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 221 interface Serial1 122

interface Serial3
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 logging event subif-link-status
 logging event dlci-status-change
 clockrate 56000
 no frame-relay inverse-arp
 frame-relay intf-type dce
 frame-relay route 321 interface Serial1 123

 

To verify that your frame relay configuration is functioning correctly, run the global command show frame route on the frame relay switch. If you see active next to all frame routes as shown below, you're in good shape.

Show Frame Route

If you see anything else - say, the word "inactive" - then there is a problem.

 

Troubleshooting A Frame Relay Switch

The key to troubleshooting your frame switch is that you cannotconcentrate on the frame switch's config. You can get that part perfect, but if you're using other DLCIs on your routers or there's a physical issue - perhaps you forgot to open some interfaces - you're not going to get the active frame routes you want.

 

Just make sure you're got all the appropriate interfaces open, don't forget the clockrate and frame-relay route commands on the frame switch, and you'll successfully add this important device to your Cisco lab!

More Frame Relay Switch Configuration Tips:

How to Configure Cisco Routers as Frame Relay Switch (FRS)?

Read more
1 2 > >>