Overblog Follow this blog
Edit post Administration Create my blog
Cisco & Cisco Network Hardware News and Technology

How to Configure a Cisco Layer 3 switch-Inter VLAN Routing?

April 12 2012 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Switches - Cisco Firewall

 

Cisco Catalyst switches equipped with the Enhanced Multilayer Image (EMI) can work as Layer 3 devices with full routing capabilities. Example switch models that support layer 3 routing are the 3550, 3750, 3560 etc.

On a Layer3-capable switch, the port interfaces work as Layer 2 access ports by default, but you can also configure them as “Routed Ports” which act as normal router interfaces. That is, you can assign an IP address directly on the routed port. Moreover, you can configure also a Switch Vlan Interface (SVI) with the “interface vlan” command which acts as a virtual layer 3 interface on the Layer3 switch.

On this post I will describe a scenario with a Layer3 switch acting as “Inter Vlan Routing” device together with two Layer2 switches acting as closet access switches. See the diagram below:

How-to-Configure-a-Cisco-Layer-3-switch-Inter-VLAN--copy-1.jpg

Interface Fa0/48 of the Layer3 switch is configured as a Routed Port with IP address 10.0.0.1. Two Vlans are configured on the L3 switch, Vlan10 and Vlan20. For Vlan10 we will create an SVI with IP address 10.10.10.10 and for Vlan20 an SVI with IP address 10.20.20.20. These two IP addresses will be the default gateway addresses for hosts belonging to Vlan10 and Vlan20 on the Layer2 switches respectively. That is, hosts connected on Vlan10 on the closet L2 switches will have as default gateway the IP address 10.10.10.10. Similarly, hosts connected on Vlan20 on the closet switches will have address 10.20.20.20 as their default gateway. Traffic between Vlan10 and Vlan20 will be routed by the L3 Switch (InterVlan Routing). Also, all interfaces connecting the three switches must be configured as Trunk Ports in order to allow Vlan10 and Vlan20 tagged frames to pass between switches. Let’s see a configuration snapshot for all switches below:

Cisco L2 Switch (same configuration for both switches)

!  Create VLANs 10 and 20 in the switch database
Layer2-Switch# configure terminal
Layer2-Switch(config)# vlan 10
Layer2-Switch(config-vlan)# end

 

Layer2-Switch(config)# vlan 20
Layer2-Switch(config-vlan)# end

 

!  Assign Port Fe0/1 in VLAN 10
Layer2-Switch(config)# interface fastethernet0/1
Layer2-Switch(config-if)# switchport mode access
Layer2-Switch(config-if)# switchport access vlan 10
Layer2-Switch(config-if)# end

 

!  Assign Port Fe0/2 in VLAN 20
Layer2-Switch(config)# interface fastethernet0/2
Layer2-Switch(config-if)# switchport mode access
Layer2-Switch(config-if)# switchport access vlan 20
Layer2-Switch(config-if)# end

 

!  Create Trunk Port Fe0/24
Layer2-Switch(config)# interface fastethernet0/24
Layer2-Switch(config-if)# switchport mode trunk
Layer2-Switch(config-if)# switchport trunk encapsulation dot1q
Layer2-Switch(config-if)# end

 

Cisco Layer 3 Switch

! Enable Layer 3 routing
Layer3-Switch(config) # ip routing

 

!  Create VLANs 10 and 20 in the switch database
Layer3-Switch# configure terminal
Layer3-Switch(config)# vlan 10
Layer3-Switch(config-vlan)# end

 

Layer3-Switch(config)# vlan 20
Layer3-Switch(config-vlan)# end

 

!  Configure a Routed Port for connecting to the ASA firewall 
Layer3-Switch(config)# interface FastEthernet0/48
Layer3-Switch(config-if)# description To Internet Firewall
Layer3-Switch(config-if)# no switchport
Layer3-Switch(config-if)# ip address 10.0.0.1 255.255.255.252

 

!  Create Trunk Ports Fe0/47 Fe0/46
Layer3-Switch(config)# interface fastethernet0/47
Layer3-Switch(config-if)# switchport mode trunk
Layer3-Switch(config-if)# switchport trunk encapsulation dot1q
Layer3-Switch(config-if)# end

 

Layer3-Switch(config)# interface fastethernet0/46
Layer3-Switch(config-if)# switchport mode trunk
Layer3-Switch(config-if)# switchport trunk encapsulation dot1q
Layer3-Switch(config-if)# end

 

!  Configure Switch Vlan Interfaces (SVI)
Layer3-Switch(config)# interface vlan10
Layer3-Switch(config-if)# ip address 10.10.10.10 255.255.255.0
Layer3-Switch(config-if)# no shut

 

Layer3-Switch(config)# interface vlan20
Layer3-Switch(config-if)# ip address 10.20.20.20 255.255.255.0
Layer3-Switch(config-if)# no shut

 

!  Configure default route towards ASA firewall
Layer3-Switch(config)# ip route 0.0.0.0 0.0.0.0 10.0.0.2

 

NOTE: More discussion of Cisco Layer 3 switch-InterVLAN Routing Configuration from Cisco users you can visit: networkstraining.com

Discussion: Router vs. Layer 3 Switches

Layer 2 Switches & Layer 3 switches

 

Share this post

Repost 0

Comment on this post

maitre marabout de la grande loge noire 09/13/2017 23:26

Ne vous laissez plus allez pas les marabouts qui ne détiennes pas le maximum de la puissance de la magie noire car nous recevrons assez de plaintes de jours en jours de ces quelques marabout qui ne donne pas satisfaction aux personnes en besoin urgent, vous pouvez désormais vous adressez et venir vous-même à la grande secte noire des plus grand marabout du monde L’unique adresse de la grande secte est le : sectediva@gmail.com/ 0022967238433 DISPONIBLE 24H SUR 24H La grande secte noire d’Afrique secte diva est la secte noire des plus grands marabouts du monde ;c’est la secte qui donne autorité au marabouts et qui détiens les plus grandes puissances de la magie noire ,elle est là pour tous vos problèmes ; vous devriez savoir que la grande secte noire détiens tous les puissances magique que vous recherchez auprès de qui qu’on la secte diva porte son aide a tous travaux de guérison des maladies Retour de l'être aimé Retour d'affection en trois jours Portefeuille magique Bague magique An-tir bal spirituel Lunette magique réussir vos affaires , agrandir votre entreprises et trouver de bon marché et partenaires? Devenir star Gagner aux jeux de hasard trouvé un bon travail? Avoir la promotion au travail Avancement au bureau Envoûtements Affaire, crise conjugale Dés-envoûtement Protection contre les esprits maléfices Protection contre les mauvais sorts Chance au boulot évolution de poste au boulot Chance en amour Chance partout La puissance sexuelle. Abandon de la cigarette et de l'alcool Amulette contre accident Poudre amaigrissement payer vos dettes faire pacte avec le diable pour la gloire et la richesse Résultat très efficaces. Travail très rapide et double efficacité. Plus de soucis à vous faire, le grande secte noire des grands marabouts du monde est la solution à tous vos problèmes. Ne vous laissez pas allez pas les marabouts qui ne détiennes pas le total de la puissance de la magie noire L’unique adresse de la grande secte est le : UNIQUE ADRESSE DE LA GRANDE SECTE NOIRE DES GRANDS MARABOUTS DU MONDE. sectediva@gmail.com/ 0022967238433/Rue du foret sacré de djokololo /République du BENIN ; TERRE DES VODOUN DISPONIBLE 24H SUR 24H Vous pouvez parcourir nos sites : http://pacteavecledibable.over-blog.com/ https://sectedivadafrique.wordpress.com https://logedelasectediva.simplesite.com/ http://sectediva.onlc.eu https://logedelamagienoire.blogspot.com/ www.sectediva.fr http://pacteavecsatan.over-blog.com https://grandsectenoiredafrique.e-monsite.com pacteavecledibale.jimdo.com http://pacteaveclagrandesectenoire.over-blog.com QUELQUES SOIT VOTRE PROBLÈME LA SECTE VOUS PERMETTRA DE RENTRE DANS LE RAND DES RICHES CONTACTE http://sectedivadafrique blog.com/ http://pacteavecsatan.over-blog.com EMAIL: sectediva@gmail.com Téléphone /whatzapp :00229 67238433 ADRESSE FACEBOOK: Secte afrique/https://web.facebook.com/profile.php?id=100017703900363

trust flow backlinks 02/17/2017 15:52

Great, This specific net webpage is seriously thrilling and enjoyment to learn. I’m an enormous fan from the subjects mentioned.

Obat kutil kelamin 11/29/2016 02:50

Great resource! Thanks for sharing

Cara Mengobati Ambeien 11/13/2016 20:09

Thanks for sharing the article, very interesting and rewarding, Thank's again

Obat Ambeien 11/13/2016 20:09

Nice post, Thanks for share