Overblog Follow this blog
Administration Create my blog
Cisco & Cisco Network Hardware News and Technology

Cisco CCNA Tips–Answers to Protocols & Services Questions

February 28 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

Here we will offer some Cisco CCNA Tips–Protocols & Services Questions with Answers and Explanations

Question 1

An administrator attempts a traceroute but receives a “Destination Unreachable” message. Which protocol is responsible for that message?

A. RARP 
B. RUDP 
C. ICMP 
D. SNMP

Answer: C

Explanation

The ICMP destination unreachable message is generated by a router (which is reachable) to inform the source host that the destination unicast address is unreachable.

 

Question 2

DNS servers provide what service?

A. They run a spell check on host names to ensure accurate routing 
B. They convert domain names into IP address 
C. Given an IP address.they determine the name of the host that is sought 
D. They map individual hosts to their specific IP addresses

Answer: B

Explanation

For example, when you open a web browser (IE, Firefox…) and type a domain (like google.com). This domain will be sent to a DNS server. The DNS server looks up this domain in its database and sends back a corresponding IP address which you can use to access that website.

Note: A DNS server can be a dedicated device for DNS service or integrated into a networking device (like router).

 

Question 3

Which of the following protocols uses both TCP and UDP ports?

A. SMTP 
B. Telnet 
C. FTP
D. DNS 

Answer: D

Explanation

DNS can use either the User Datagram Protocol (UDP) or Transmission Control Protocol (TCP) with a destination port of 53.

Note:

Simple Mail Transfer Protocol (SMTP) is specified for mail transport and uses TCP port 25.
Telnet uses TCP on port 23.
File Transfer Protocol (FTP) uses TCP on port 20, 21.
Trivial File Transfer Protocol (TFTP) uses UDP on port 69.
HTTP Secure (HTTPS) uses TCP on port 443.

 

Question 4

Which protocol should be used to establish a secure terminal connection to a remote network device?

A. ARP 
B. SSH
C. Telnet
D. WEP
E. SNMPv1
F. SNMPv2

Answer: B

Explanation

Secure Shell (SSH) protocols secure terminal session data across insecure environments such as the internet.

 

Question 5

A network administrator issues the ping 192.168.2.5 command and successfully tests connectivity to a host that has been newly connected to the network. Which protocols were used during the test? (Choose two)

A. ARP
B. CDP
C. DHCP
D. DNS
E. ICMP

Answer: A E

Explanation

In this question we are not sure the host 192.168.2.5 is in or outside the local network. But in both cases the ARP protocol are used to get the MAC address:

If host 192.168.2.5 is inside the local network, our device will broadcast an ARP Request to ask the MAC address of the host 192.168.2.5 (something like “If your IP is 192.168.2.5, please send me your MAC address”).
If host 192.168.2.5 is outside the local network, our device will broadcast an ARP Request to ask the MAC address of the local port (the port in the same subnet with our device) of the default gateway. Notice that the IP of the default gateway has been already configured in our device.

-> In both cases, our device must broadcast an ARP Request -> A is correct.

After getting the ARP of the destination device, our device will use ICMP protocol to send the “ping” -> E is correct.

Note: The question states “the host has been newly connected to the network” which means our device hasn’t had the MAC address of this host in its ARP table -> it needs to send ARP Request.

There is one situation which makes answer A incorrect: the newly connected host is outside the network but our device has already learned the MAC address of the default gateway -> in this case no ARP Request will be sent. So I assume the question wants to imply the newly connected host is in the local network.

 

Question 6

Which network protocol does DNS use?

A. FTP 
B. TFTP 
C. TCP 
D. UDP
E. SCP

Answer: D

Explanation

It is funny that in Question 3 I answered “DNS uses both TCP & UDP” but in this question we can only choose one answer and it should be “DNS uses UDP”. So I wish to explain more:

Normally a client sends a DNS Query using UDP Protocol over Port 53. If it does not get response from a DNS Server, it must re-transmit the DNS Query using TCP after 3-5 seconds. So we can say DNS prefers using UDP to TCP -> the answer should be UDP.

 

Question 7

When two hosts are trying to communicate across a network, how does the host originating the communication determine the hardware address of the host that it wants to “talk” to?

A. RARP request
B. Show Network Address request
C. Proxy ARP request
D. ARP request
E. Show Hardware Address request

Answer: D

Explanation

The address resolution protocol (ARP) is a protocol used to map IP network addresses to the hardware addresses.

If the destination host is inside the local network, the originating host will broadcast an ARP Request to ask the MAC address of that host.
If the destination host is outside the local network, the originating host will broadcast an ARP Request to ask the MAC address of the local port (the port in the same subnet with our device) of the default gateway. Notice that the IP of the default gateway has been already configured in our device.

 

Question 8

Refer to the exhibit, Host A pings interface S0/0 on router 3, what is the TTL value for that ping?

Question-8.jpg

A. 253
B. 252 
C. 255 
D. 254

Answer: A

Explanation

From the CCNA ICND2 Exam book: “Routers decrement the TTL by 1 every time they forward a packet; if a router decrements the TTL to 0, it throws away the packet. This prevents packets from rotating forever.” I want to make it clear that before the router forwards a packet, the TTL is still remain the same. For example in the topology above, pings to S0/1 and S0/0 of Router 2 have the same TTL.

The picture below shows TTL values for each interface of each router and for Host B. Notice that Host A initializes ICMP packet with a TTL of 255:

Question-802.jpg

More Topics Related to Networking Protocols:

BGP Routing Protocol Tips You Need to Know

Routing Information Protocol & RIP Configuration

How to Configure IGRP (Interior Gateway Routing Protocol)?

How to Configure Basic NAT with Overloading?

10 Things to Know About the Cisco CCNA Voice Certification

Read more

Understanding EIGRP by FAQs

February 26 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Networking

This DOC contains frequently asked questions (FAQs) about IP Enhanced Interior Gateway Routing Protocol (EIGRP).

EIGRP.png

Q. Does EIGRP require an ip default-network command to propagate a default route?

A. Although EIGRP can propagate a default route using the default network method, it is not required. EIGRP redistributes default routes directly.

 

Q. Should I always use the eigrp log-neighbor-changes command when I configure EIGRP?

A. Yes, this command makes it easy to determine why an EIGRP neighbor was reset. This reduces troubleshooting time.

 

Q. Does EIGRP support secondary addresses?

A. EIGRP does support secondary addresses. Since EIGRP always sources data packets from the primary address, Cisco recommends that you configure all routers on a particular subnet with primary addresses that belong to the same subnet. Routers do not form EIGRP neighbors over secondary networks. Therefore, if all of the primary IP addresses of routers do not agree, problems can arise with neighbor adjacencies.

 

Q. What debugging capabilities does EIGRP have?

A. There are protocol-independent and -dependent debug commands. There is also a suite of show commands that display neighbor table status, topology table status, and EIGRP traffic statistics. Some of these commands are:

 

Q. What does the word serno mean on the end of an EIGRP topology entry when you issue the show ip eigrp topology command?

A. For example:

show ip eigrp topology

P 172.22.71.208/29, 2 successors, FD is 46163456

via 172.30.1.42 (46163456/45651456), Serial0.2, serno 7539273

via 172.30.2.49 (46163456/45651456), Serial2.6, serno 7539266

Serno stands for serial number. When DRDBs are threaded to be sent, they are assigned a serial number. If you display the topology table at the time an entry is threaded, it shows you the serial number associated with the DRDB.

 

Threading is the technique used inside the router to queue items up for transmission to neighbors. The updates are not created until it is time for them to go out the interface. Before that, a linked list of pointers to items to send is created (for example, the thread).

 

These sernos are local to the router and are not passed with the routing update.

 

Q. What percent of bandwidth and processor resources does EIGRP use?

A. EIGRP version 1 introduced a feature that prevents any single EIGRP process from using more than fifty percent of the configured bandwidth on any link during periods of network convergence. Each AS or protocol (for instance, IP, IPX, or Appletalk) serviced by EIGRP is a separate process. You can use the ip bandwidth-percent eigrpinterface configuration command in order to properly configure the bandwidth percentage on each WAN interface. Refer to the EIGRP White Paper for more information on how this feature works.

In addition, the implementation of partial and incremental updates means that EIGRP sends routing information only when a topology change occurs. This feature significantly reduces bandwidth use.

 

The feasible successor feature of EIGRP reduces the amount of processor resources used by an autonomous system (AS). It requires only the routers affected by a topology change to perform route re-computation. The route re-computation only occurs for routes that were affected, which reduces search time in complex data structures.

 

Q. Does EIGRP support aggregation and variable length subnet masks?

A. Yes, EIGRP supports aggregation and variable length subnet masks (VLSM). Unlike Open Shortest Path First (OSPF), EIGRP allows summarization and aggregation at any point in the network. EIGRP supports aggregation to any bit. This allows properly designed EIGRP networks to scale exceptionally well without the use of areas. EIGRP also supports automatic summarization of network addresses at major network borders.

 

Q. Does EIGRP support areas?

A. No, a single EIGRP process is analogous to an area of a link-state protocol. However, within the process, information can be filtered and aggregated at any interface boundary. In order to bound the propagation of routing information, you can use summarization to create a hierarchy.

 

Q. Can I configure more than one EIGRP autonomous system on the same router?

A. Yes, you can configure more than one EIGRP autonomous system on the same router. This is typically done at a redistribution point where two EIGRP autonomous systems are interconnected. Individual router interfaces should only be included within a single EIGRP autonomous system.

Cisco does not recommend running multiple EIGRP autonomous systems on the same set of interfaces on the router. If multiple EIGRP autonomous systems are used with multiple points of mutual redistribution, it can cause discrepancies in the EIGRP topology table if correct filtering is not performed at the redistribution points. If possible, Cisco recommends you configure only one EIGRP autonomous system in any single autonomous system. You can also use another protocol, such as Border Gateway Protocol (BGP), in order to connect the two EIGRP autonomous systems.

 

Q. If there are two EIGRP processes that run and two equal paths are learned, one by each EIGRP process, do both routes get installed?

A. No, only one route is installed. The router installs the route that was learned through the EIGRP process with the lower Autonomous System (AS) number. In Cisco IOS Software Releases earlier than 12.2(7)T, the router installed the path with the latest timestamp received from either of the EIGRP processes. The change in behavior is tracked by Cisco bug ID CSCdm47037.

 

Q. What does the EIGRP stuck in active message mean?

A. When EIGRP returns a stuck in active (SIA) message, it means that it has not received a reply to a query. EIGRP sends a query when a route is lost and another feasible route does not exist in the topology table. The SIA is caused by two sequential events:

  • The route reported by the SIA has gone away.
  • An EIGRP neighbor (or neighbors) have not replied to the query for that route.

When the SIA occurs, the router clears the neighbor that did not reply to the query. When this happens, determine which neighbor has been cleared. Keep in mind that this router can be many hops away. Refer to What Does the EIGRP DUAL-3-SIA Error Message Mean? for more information.

 

Q. What does the neighbor statement in the EIGRP configuration section do?

A. The neighbor command is used in EIGRP in order to define a neighboring router with which to exchange routing information. Due to the current behavior of this command, EIGRP exchanges routing information with the neighbors in the form of unicast packets whenever the neighbor command is configured for an interface. EIGRP stops processing all multicast packets that come inbound on that interface. Also, EIGRP stops sending multicast packets on that interface.

 

The ideal behavior of this command is for EIGRP to start sending EIGRP packets as unicast packets to the specified neighbor, but not stop sending and receiving multicast packets on that interface. Since the command does not behave as intended, the neighbor command should be used carefully, understanding the impact of the command on the network.

 

Q. Why does the EIGRP passive-interface command remove all neighbors for an interface?

A. The passive-interface command disables the transmission and receipt of EIGRP hello packets on an interface. Unlike IGRP or RIP, EIGRP sends hello packets in order to form and sustain neighbor adjacencies. Without a neighbor adjacency, EIGRP cannot exchange routes with a neighbor. Therefore, the passive-interface command prevents the exchange of routes on the interface. Although EIGRP does not send or receive routing updates on an interface configured with the passive-interface command, it still includes the address of the interface in routing updates sent out of other non-passive interfaces. Refer to How Does the Passive Interface Feature Work in EIGRP?For more information.

 

Q. Why are routes received from one neighbor on a point-to-multipoint interface that runs EIGRP not propagated to another neighbor on the same point-to-multipoint interface?

A. The split horizon rule prohibits a router from advertising a route through an interface that the router itself uses to reach the destination. In order to disable the split horizon behavior, use the no ip split-horizon eigrp as-numberinterface command. Some important points to remember about EIGRP split horizon are:

  • Split horizon behavior is turned on by default.
  • When you change the EIGRP split horizon setting on an interface, it resets all adjacencies with EIGRP neighbors reachable over that interface.
  • Split horizon should only be disabled on a hub site in a hub-and-spoke network.
  • Disabling split horizon on the spokes radically increases EIGRP memory consumption on the hub router, as well as the amount of traffic generated on the spoke routers.
  • The EIGRP split horizon behavior is not controlled or influenced by the ip split-horizon command.

For more information on split horizon and poison reverse, refer to Split Horizon and Poison Reverse. For more information on commands, refer to EIGRP Commands.

 

Q. When I configure EIGRP, how can I configure a network statement with a mask?

A. The optional network-mask argument was first added to the network statement in Cisco IOS Software Release 12.0(4)T. The mask argument can be configured in any format (such as in a network mask or in wild card bits). For example, you can use network 10.10.10.0 255.255.255.252 or network 10.10.10.0 0.0.0.3.

 

Q. I have two routes: 172.16.1.0/24 and 172.16.1.0/28. How can I deny 172.16.1.0/28 while I allow 172.16.1.0/24 in EIGRP?

A. In order to do this you need to use a prefix-list, as shown here:

router eigrp 100

       network 172.16.0.0

       distribute-list prefix test in

       auto-summary

       no eigrp log-neighbor-changes

       !

       ip prefix-list test seq 5 permit 172.16.1.0/24

This allows only the 172.16.1.0/24 prefix and therefore denies 172.16.1.0/28.

 

Note: The use of ACL and distribute-list under EIGRP does not work in this case. This is because ACLs do not check the mask, they just check the network portion. Since the network portion is the same, when you allow 172.16.1.0/24, you also allow 172.16.1.0/28.

 

Q. I have a router that runs Cisco Express Forwarding (CEF) and EIGRP. Who does load-balancing when there are multiple links to a destination?

A. The way in which CEF works is that CEF does the switching of the packet based on the routing table which is populated by the routing protocols such as EIGRP. In short, CEF does the load-balancing once the routing protocol table is calculated. Refer to How Does Load Balancing Work? for more information on load balancing.

 

Q. How do you verify if the EIGRP Non Stop Forwarding (NSF) feature is enabled?

A. In order to check the EIGRP NSF feature, issue the show ip protocols command. Here is the sample output:

show ip protocols

  Routing Protocol is "eigrp 101"

 

  Outgoing update filter list for all interfaces is not set

 

  Incoming update filter list for all interfaces is not set

 

  Default networks flagged in outgoing updates

 

  Default networks accepted from incoming updates

 

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

 

  EIGRP maximum hopcount 100

 

  EIGRP maximum metric variance 1

 

  Redistributing: eigrp 101

 

  EIGRP NSF-aware route hold timer is 240s

 

  Automatic network summarization is in effect

 

  Maximum path: 4

 

  Routing for Networks:

 

  Routing Information Sources:

 

  Gateway         Distance      Last Update

 

  Distance: internal 90 external 170

 

This output shows that the router is NSF-aware and the route-hold timer is set to 240 seconds, which is the default value.

 

Q. How can I use only one path when a router has two equal cost paths?

A. Configure the bandwidth value on the interfaces to default, and increase the delay on the backup interface so that the router does not see two equal cost paths.

 

Q. What is the difference in metric calculation between EIGRP and IGRP?

A. The EIGRP metric is obtained when you multiply the IGRP metric by 256. The IGRP uses only 24 bits in its update packet for the metric field, but EIGRP uses 32 bits in its update packet for the metric field. For example, the IGRP metric to a destination network is 8586, but the EIGRP metric is 8586 x 256 = 2,198,016. Integer division is used when you divide 10^7 by minimum BW, so the calculation involves integer division, which leads to a variation from manual calculation.

 

Q. What is the EIGRP Stub Routing feature?

A. The Stub routing feature is used to conserve bandwidth by summarizing and filtering routes. Only specified routes are propagated from the remote (Stub) router to the distribution router because of the Stub routing feature. For more information about the Stub routing feature, refer to EIGRP Stub Routing. The EIGRP stub feature can be configured on the switch with the eigrp stub [receive-only] [leak-map name] [connected] [static] [summary] [redistributed] command. This feature can be removed with the no eigrp stub command. When you remove theeigrp stub command from the switch, the switch that runs the IP Base image throws this error:

EIGRP is restricted to stub configurations only

This issue can be resolved if you upgrade to Advanced Enterprise Images. This error is documented inCSCeh58135.

 

Q. How can I send a default route to the Stub router from the hub?

A. Do this under the outbound interface on the hub router with the ip summary-address eigrp X 0.0.0.0 0.0.0.0command. This command suppresses all the more specific routes and only sends the summary route. In the case of the 0.0.0.0 0.0.0.0, it means it suppresses everything, and the only route that is in the outbound update is 0.0.0.0/0. One drawback to this method is that EIGRP installs a 0.0.0.0/0 route to Null0 is the local routing table with an admin distance of 5.

 

Q. What are different route types in EIGRP?

A. There are three different types of routes in EIGRP:

  • Internal Route—Routes that are originated within the Autonomous System (AS).
  • Summary Route—Routes that are summarized in the router (for example, internal paths that have been summarized).
  • External Route—Routes that are redistributed to EIGRP.

 

Q. How do you redistribute an IPv6 default route in EIGRP?

A. For redistributing an IPv6 default route in EIGRP, a sample configuration is shown here:

ipv6 prefix-list DEFAULT-ONLY-V6 seq 10 permit ::/0

route-map DEFAULT_2EIGRP-V6 permit 10

match ipv6 address prefix-list DEFAULT-ONLY-V6

router eigrp Starz_EIGRP

address-family ipv6 unicast

redistribute static route-map DEFAULT_2EIGRP-V6

 

Q. How does EIGRP behave over a GRE tunnel compared to a directly connected network?

A. EIGRP will use the same administrative distance and metric calculation for the GRE tunnel. The cost calculation is based on bandwidth and delay. The bandwidth and delay of the GRE tunnel will be taken from the tunnel interface configured on the router. The tunnel will also be treated like a directly connected network. If there are two paths to reach a network either through a VLAN interface or tunnel interface, EIGRP prefers the Virtual-Access Interface (VAI) VLAN interface because the VLAN interface has greater bandwidth than the tunnel interface. In order to influence the routing through the tunnel interface, increase the bandwidth parameter of the tunnel interface, or increase the delay parameter of the VLAN interface.

 

Q. What is an offset-list, and how is it useful?

A. The offset-list is an feature used to modify the composite metrics in EIGRP. The value configured in the offset-list command is added to the delay value calculated by the router for the route matched by an access-list. An offset-list is the preferred method to influence a particular path that is advertised and/or chosen.

 

Q. How can I tag external routes in EIGRP?

A. You can tag routes that EIGRP has learned from another routing protocol using a 32 bit tag value. Starting with ddts CSCdw22585, internal routes can also be tagged. However, the tag value cannot exceed 255 due to packet limitations for internal routes.

 

Q. What are the primary functions of the PDM?

A. EIGRP supports 3 protocol suites: IP, IPv6, and IPX. Each of them has its own PDM. These are the primary functions of PDM:

  • Maintaining the neighbor and topology tables of EIGRP routers that belong to that protocol suite
  • Building and translating protocol specific packets for DUAL
  • Interfacing DUAL to the protocol specific routing table
  • Computing the metric and passing this information to DUAL; DUAL handles only the picking of the feasible successors (FSs)
  • Implement filtering and access lists.
  • Perform redistribution functions to/from other routing protocols.

 

Q. What are the various load-balancing options available in EIGRP?

A. The offset-list can be used to modify the metrics of routes that EIGRP learns through a particular interface, or PBR can be used.

 

Q. What does the %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 10.254.0.3 (Tunnel0) is down: holding time expired error message mean?

A. This message indicates that the router has not heard any EIGRP packets from the neighbor within the hold-time limit. Because this is a packet-loss issue, check for a Layer 2 problem.

 

Q. Is there a IPv6 deployment guide that includes EIGRPv6?

A. Refer to Deploying IPv6 in Branch Networks for more information.

 

Q. From the 16:29:14.262 Poison squashed: 10.X.X.X/24 reverse message, what does poison squashed mean?

A. The router threads a topology table entry as a poison in reply to an update received (the router sets up for poison reverse). While the router is building the packet that contains the poison reverse, the router realizes that it does not need to send it. For example, if the router receives a query for the route from the neighbor, it is currently threaded to poison. Thus, it sends the poison squashed message.

 

Q. Is it normal that EIGRP takes over 30 seconds to converge?

A. EIGRP taking longer to converge under heavy CPU usage is a normal behavior. EIGRP convergence is faster when you lower the hold time. The lowest values for hello and hold time are 1 second and 3 seconds respectively. For example:

Router(Config)# interface Fa0/0

!--- (Under an interface directly connected to EIGRP peers.)

Router(Config-if)#ip hello-interval eigrp 1

Router(Config-if)#ip hold-time eigrp 3

Note: Make sure that the hold time is changed on both ends.

For more information on EIGRP performance related issues, refer to How to resolve EIGRP performance problems.

 

Resource from

http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012dac4.shtml

More Related Topics:

Why Is Cisco Bothering With “Open” EIGRP?

How to Configure IGRP (Interior Gateway Routing Protocol)?

Routing Information Protocol & RIP Configuration

How to Configure OSPF on Cisco Routers?

Read more

Virtual Private Clouds Offer Customers SLA Security

February 19 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Networking

As public cloud SLAs take heat from analysts, some enterprises say virtual private clouds offer the right mix of cloud agility and managed services reliability.

Virtual-Private-Clouds-Offer-Customers-SLA-Security.jpeg

A virtual private cloud (VPC) offers on-demand Infrastructure as a Service (IaaS) external to a customer's data center, but it runs on a dedicated infrastructure, rather than a multi-tenant infrastructure. It is usually connected to each customer using a virtual private network (VPN) or another direct network connection, rather than the public Internet.

 

As such, a virtual private cloud can offer higher service-level agreements (SLAs) than public clouds, contracting for up to 100% uptime in some cases.

 

Finding the SLA that's Just Right

Some purists might consider this managed hosting rather than cloud computing, but these distinctions aren't relevant to customers such as Taylor Erickson, vice president of IT at Lanx Inc., a company that specializes in spinal care and surgical products in Bloomfield, Colo.

 

Lanx moved its SAP application and Active Directory to a virtual private cloud hosted by Virtustream Inc., last fall. Virtustream's xStream virtual private cloud gives the company a five-nines (99.999%) uptime SLA. Penalties start at 99.949% uptime, and were negotiated by Lanx with the help of an analyst firm to review the contract, Erickson said.

 

With the choice between Virtustream's xStream VPC and a public cloud provider Erickson declined to name, the virtual private cloud SLA was just one of the reasons the company chose Virtustream.

 

In fact, enterprise managed hosting providers such as ViaWest and Hosting.com tend to offer 100% uptime SLAs , but Virtustream's demonstrated expertise at hosting SAP appealed to Lanx, as did Virtustream's cost, which can be as low as half that of such services.  

 

And 99.999% uptime was still more than the company might have been able to provide on its own. For example, a week after the company's migration, an air conditioning unit in Lanx's building failed, and the server room temperature soared to 98 degrees.

 

"But our mission-critical SAP was up and going because we'd migrated to a cloud provider," Erickson said.

 

Virtual Private Cloud a Happy Medium between Public and Private Cloud

Other users say public cloud, which tends to be the lowest-cost and most elastic of all service types, has undeniable appeal, but that using it requires very careful planning.

 

We're all used to pushing a hoster over a barrel to get what we want. We get that, but they custom configure the environment just for us and they sign us up for a three-year commitment.

                      ---James Staten, analyst with Forrester Research

 

"You can never take [public cloud] off the table," said Dave Robbins, senior vice president and CIO of Ellie Mae, maker of an electronic loan origination platform and based in Pleasanton, Calif. "But if you're going to do it, what's your architecture and strategy to do it?"

 

Just carving out public cloud IaaS space without respect for regional diversity or how to get an ecosystem in place to exploit application delivery can be very low cost, but it's very low value as well, according to Robbins.

 

"It's a more complicated picture than most people think through," he said. "You have to look at the entire architecture."

 

In the meantime, Ellie Mae has found a happy medium in a Tier 3 Inc., virtual private cloud, tied in to an on-premise FlexPod environment that uses Cloupia, now owned by Cisco Systems Inc.

 

Space on Tier 3's infrastructure was used by the company last year as it migrated from an older infrastructure to the new one built on FlexPods, and simultaneously launched new products and services. Some production applications ran in Tier 3 as this process took place, and the company also uses Tier 3's VPC for QA and test systems.

 

VPCs Bridge a Disconnect between Public Cloud SLAs and Enterprise Expectations

Some SLAs are cryptic, but what's really more of a problem is the typical enterprise customer's disconnect in expectation from what they normally get from hosting providers and managed service providers and what they're going to get from public cloud, said James Staten, analyst with Forrester Research.

 

"We're all used to pushing a hoster over a barrel to get what we want. We get that, but they custom configure the environment just for us and they sign us up for a three-year commitment," he said.

 

Customers pursuing public cloud services tend not to want to be locked in to such commitments, and in some cases using a standardized service is going to be preferable to one custom-managed for the user, Staten said. But in these cases, the SLA is going to be lower.

 

Article written by Beth Pariseau from

http://searchcloudcomputing.techtarget.com/news/2240176544/Virtual-private-clouds-offer-customers-SLA-security 

More Related Networking News and Tips:

How to Use Cisco IP SLA to Manipulate Route Forwarding Decisions?

How to Configure Cisco IP SLA?

CCNP SWITCH 642-813 Guide: Configuring IP SLA

Cisco to Acquire Israeli Mobile Startup Intucell for $475 Million

 

Read more

Benefits of Dynamic Routing

February 17 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco & Cisco Network

As a network administrator, you must also know dynamic IP routing like the back of your hand. In this article, we'll explore dynamic IP routing and you'll learn the practical information that you need to know about it.

 

Routing in General

To review from the last tip, the router learns the next hop for packets using one of two methods:

  1. Static routing: With static routing, you -- as the administrator -- manually enter the routes and tell the router, for each IP network, what next hop that traffic should be delivered to.
  2. Dynamic routing: With dynamic routing, you -- as the administrator -- configure a routing protocol on your network interfaces. Your routing protocol learns about other routers automatically. Your router and the other routers exchange routes, and each learns about the networks that the other is connected to. When new networks are added or removed, the routers update each other.

 

Static Routing Issues

With static routing, you are telling your router to send traffic with a destination IP address to a router with an IP address of x.x.x.x. This is handy for a small network with very few routes or for someone who wants to have absolute control, but it can become very cumbersome as your network grows. To keep a multi-site wide-area network fully connected (fully meshed) via static routes, you have to create a route on every router for every other router. This mean that, as you add more sites, the number of routes you have to create increases exponentially, and when sites go down or links are performing poorly, any corrections must be entered manually.

 

Benefits of Dynamic Routing

A dynamic routing protocol can resolve these issues for you. Here are some general benefits of using a dynamic routing protocol:

  • More automation: Routing updates are automatically sent to all other routers.
  • Change notification: The dynamic routing protocol may be able to reroute traffic around a link that is down or congested.
  • Greater uptime for users: Because the routing protocol has intelligence and can react faster, the users may see more uptime.
  • Greater network throughput: Because the routing protocol may be able to calculate the most responsive network link to use, the users may see less latency and more performance out of the network.
  • Less work for administrators: As the network grows, the administrator doesn't have to worry about configuring all the other routers on the network. Instead, the administrator configures the dynamic routing protocol on the new router to talk to the other routers and let them know what networks the new router has to offer.

 

Gotchas of Dynamic Routing

Don't think that dynamic routing protocols are perfect, however. Here are some possible gotchas of using dynamic routing protocols:

  • Routers may need more CPU and RAM to hold routing tables and calculate dynamic routes.
  • Dynamic routing protocols aren't perfect and can experience routing loops in some cases.
  • Dynamic routing protocols will introduce complexity to your network. You will need to understand how to configure and troubleshoot the new dynamic routing protocols.

 

Dynamic Routing Protocols

You may be wishing you had some examples of dynamic routing protocols. I'm not going to cover or compare all possible routing protocols, but let's talk about the dynamic routing protocols you need to know.

 

First off, there are the interior gateway routing protocols (IGP). These are protocols that you would use within your own network. They are the protocols that are supported by just about every router and server operating system (such as Windows 2003 Server and Linux):

  • OSPF(Open Shortest Path First)--RFC2328--is the most popular dynamic routing protocol in use today. It is an open protocol, so that any router or server operating system can run OSPF. OSPF selects the best route using "cost" as its metric. OSPF is a full-featured routing protocol and can be complex, but it can also scale to any size of network.
  • EIGRP(Enhanced Interior Gateway Routing Protocol) is a Cisco proprietary protocol. Only Cisco devices run EIGRP. EIGRP is a full-featured routing protocol, similar to OSPF. EIGRP has some great features, but unless you can guarantee that you will always have an all-Cisco network, I would recommend an open protocol like OSPF, instead. EIGRP replaced IGRP, its predecessor. With EIGRP, the metric used to select the best route is calculated using a formula that takes into account the bandwidth, reliability, load and delay of the link.
  • RIP (Routing Information Protocol) Version 2 -- RFC2453 -- is also an open source protocol. Version 2 of RIP is what you should use today as it provides support for VLSM (Variable Length Subnet Mask). RIP is the simplest and easiest routing protocol to configure, but it also has fewer features than OSPF and is limited to routing for a network with fewer than 15 hops. RIP works very well for a small network that doesn't plan on growing large, however. Another great thing about RIP is that it is commonly supported by even small routers and firewalls.

And, in a class by itself, there is Border Gateway Protocol (BGP):

  • BGP (Border Gateway Protocol) is the routing protocol of the Internet. BGP is an Exterior Gateway Protocol (EGP). What that means is that BGP is used by routers that make routing decisions on the Internet. Just because your home or work router has a connection to the Internet, you don't necessarily need BGP or want to run it. Once your router has more than one dedicated connection to the Internet from business-class providers, you may want to look at running BGP. BGP is a path-vector protocol, and it selects the best route, unlike other routing protocols. BGP uses the "AS-PATH" as its routing metric and would select the route that has the shortest path through the Internet.

 

Configuring Dynamic Routing

So all this theoretical stuff is great, right? It gives you a good foundation, but you probably want to see how to configure a dynamic routing protocol.

 

Let's say that we have the basic network, shown below:

 

 Configuring-dynamic-routing.jpg

It is our job to configure RIP between these two locations so that each network knows about the other router's networks. Assuming that all normal router IP addressing is configured and interfaces have been enabled, we need issue only a few simple commands on each router to accomplish this.

 

Here is the configuration:

Location A
Router rip 
Ver 2
No auto-summary
Network 10.1.1.0
Network 63.248.129.0

Location A
Router rip
Ver 2
No auto-summary
Network 10.2.2.0
Network 63.248.129.0

What this does is:

Enter routing configuration mode on each router.
Enable Version 2 of the RIP routing protocol.
Enable RIP routing on both the LAN and the WAN networks. This will tell the router both to advertise these networks to other routers and to try and find other routers on these networks.

 

Once completed, here is the routing table and ping output for Location A:

Location-A1.jpg

Location-A2.jpg

Location-A3.jpg

As you can see, each router knows about the other router's LAN networks through RIP (the "R" in the routing table source shows that these routes were learned through RIP). Also, each router can ping other routers' Ethernet interfaces.

 

We could have accomplished the same connectivity with only one static route on each router. However, as this network grows from two routers to 20 or 200, the time needed to administer static routing would be a horrible administrative burden.

 

As a network administrator, you should have some basic knowledge of the four most popular dynamic routing protocols in use today. If you are new at this, I recommend that you start by learning about RIP and move up to the other protocols from there.

---Resource from http://searchnetworking.techtarget.com/tip/Cisco-IOS-IP-routing-dynamic-routing

More Related Cisco and Network Tips:

Routing Information Protocol & RIP Configuration

Understanding Different Router Numbers

Understanding Cisco IOS Static Multicast Routes

Cisco IOS IP Routing: Static Routes

Read more

How to Configure IGRP?

February 6 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

If you are not familiar with Interior Gateway Routing Protocol (IGRP), click the following link to view an introduction to Interior Gateway Routing Protocol (IGRP).

 

Interior Gateway Routing Protocol (IGRP) Configuration

Interior Gateway Routing Protocol (IGRP) can be configured in a router using the following IOS commands. If you have a new router with a latest IOS release, you may not find Interior Gateway Routing Protocol (IGRP) configuration commands because Interior Gateway Routing Protocol (IGRP) is removed from new IOS releases.

Router(config)# router igrp ASN
Router(config-router)# network Network_ID

 

ASN in the above IOS command stands for Autonomous System Number.

 

Interior Gateway Routing Protocol (IGRP) - Lab Practice

The following diagram shows our lab setup. We have three routers, three switches and three hosts connected as below. The host names, IP addresses and the interfaces of the routers are shown in diagram. The IP addresses of the hosts are also shown in the diagram.

Interior-Gateway-Routing-Protocol--IGRP--Lab-Practice.jpg

Hostname and IP address configuration in Router01

Connect to Router01 console and use the following IOS commands to configure host name as Router01.

Router>enable
Router#configure terminal 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router01
Router01(config)#

 

Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router01 and configure IP address as 172.16.0.1/16.

Router01>enable 
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface fa0/0
Router01(config-if)#ip address 172.16.0.1 255.255.0.0
Router01(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/0 configuration mode on Router01 and configure IP address as 172.17.0.1/16. You have to set a clock rate also using the "clock rate" command on S0/0 interface, since this is the DCE side.

Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)#interface s0/0
Router01(config-if)#clock rate 64000
Router01(config-if)#ip address 172.17.0.1 255.255.0.0
Router01(config-if)#no shutdown

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Hostname and IP address configuration in Router02

Connect to Router02 console and use the following IOS commands to configure host name as Router02.

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router02
Router02(config)#

 

Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router02 and configure IP address as 172.18.0.1/16.

Router02>enable 
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface fa0/0
Router02(config-if)#ip address 172.18.0.1 255.255.0.0
Router02(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/0 configuration mode on Router02 and configure IP address as 172.17.0.2/16.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/0
Router02(config-if)#ip address 172.17.0.2 255.255.0.0
Router02(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/1 configuration mode on Router02 and configure IP address as 172.19.0.1/16. You have to set a clock rate also using the "clock rate" command on S0/1 interface, since this is the DCE side.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)#interface s0/1
Router02(config-if)#clock rate 64000
Router02(config-if)#ip address 172.19.0.1 255.255.0.0
Router02(config-if)#no shutdown

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Hostname and IP address configuration in Router03

Connect to Router03 console and use the following IOS commands to configure host name as Router03.

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router03
Router03(config)#

 

Use the following IOS commands to open the fast ethernet interface Fa0/0 configuration mode on Router03 and configure IP address as 172.20.0.1/16.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface fa0/0
Router03(config-if)#ip address 172.20.0.1 255.255.0.0
Router03(config-if)#no shutdown

 

Use the following IOS commands to open the serial interface S0/1 configuration mode on Router03 and configure IP address as 172.19.0.2/16.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)#interface s0/1
Router03(config-if)#ip address 172.19.0.2 255.255.0.0
Router03(config-if)#no shutdown

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Interior Gateway Routing Protocol (IGRP) configuration in Router01

Connect to Router01 console and use the following IOS commands to configure Interior Gateway Routing Protocol (IGRP) in Router01. Please refer the beginning of this lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS command.

 

In the IOS "network" command, shown below, we specify only the directly connected networks of this router.

Router01>enable
Router01#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router01(config)# router igrp 1
Router01(config-router)# network 172.16.0.0
Router01(config-router)# network 172.17.0.0
Router01(config-router)#exit
Router01(config)#exit
Router01#

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Interior Gateway Routing Protocol (IGRP) configuration in Router02

Connect to Router02 console and use the following IOS commands to configure Interior Gateway Routing Protocol (IGRP) in Router02. Please refer the beginning of this lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS command.

 

In the IOS "network" command, shown below, we specify only the directly connected networks of this router.

Router02>enable
Router02#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router02(config)# router igrp 1
Router02(config-router)# network 172.17.0.0
Router02(config-router)# network 172.18.0.0
Router02(config-router)# network 172.19.0.0
Router02(config-router)#exit
Router02(config)#exit
Router02#

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

Interior Gateway Routing Protocol (IGRP) configuration in Router03

Connect to Router03 console and use the following IOS commands to configure Interior Gateway Routing Protocol (IGRP) in Router03. Please refer the beginning of this lesson to view the Interior Gateway Routing Protocol (IGRP) configuration IOS command.

 

In the IOS "network" command, shown below, we specify only the directly connected networks of this router.

Router03>enable
Router03#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router03(config)# router igrp 1
Router03(config-router)# network 172.19.0.0
Router03(config-router)# network 172.20.0.0
Router03(config-router)#exit
Router03(config)#exit
Router03#

 

Do remember to run the "copy running-config startup-config" command from enable mode, if you want to save the changes you have made in the router.

 

How to View the Routing Table in Router01

After the network is converged after the initial configuration and Interior Gateway Routing Protocol (IGRP) configuration, we can use the "show ip route" to view the routing table in Router01, as shown below.

Router01>enable
Router01#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 172.16.0.0/16 is directly connected, FastEthernet0/0
C 172.17.0.0/16 is directly connected, Serial0/0
I 172.18.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
I 172.19.0.0/16 [120/1] via 172.17.0.2, 00:00:22, Serial0/0
I 172.20.0.0/16 [120/2] via 172.17.0.2, 00:00:22, Serial0/0

 

The "I" character at the beginning of a line in routing table shows that it is a route discovered byInterior Gateway Routing Protocol (IGRP) and "C" character shows that it is a directly connected network.

 

How to View the Routing Table in Router02?

When the network is converged after the initial configuration and Interior Gateway Routing Protocol (IGRP) configuration, we can use the "show ip route" to view the routing table in Router02, as shown below.

Router02>enable
Router02#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

I 172.16.0.0/16 [120/1] via 172.17.0.1, 00:00:07, Serial0/0
C 172.17.0.0/16 is directly connected, Serial0/0
C 172.18.0.0/16 is directly connected, FastEthernet0/0
C 172.19.0.0/16 is directly connected, Serial0/1
I 172.20.0.0/16 [120/1] via 172.19.0.2, 00:00:20, Serial0/1

 

The "I" character at the beginning of a line in routing table shows that it is a route discovered by Interior Gateway Routing Protocol (IGRP) and "C" character shows that it is a directly connected network.

 

How to View the Routing Table in Router03?

When the network is converged after the initial configuration and Interior Gateway Routing Protocol (IGRP) configuration, we can use the "show ip route" to view the routing table in Router03, as shown below.

Router03>enable
Router03#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

I 172.16.0.0/16 [120/2] via 172.19.0.1, 00:00:02, Serial0/1
I 172.17.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
I 172.18.0.0/16 [120/1] via 172.19.0.1, 00:00:02, Serial0/1
C 172.19.0.0/16 is directly connected, Serial0/1
C 172.20.0.0/16 is directly connected, FastEthernet0/0

 

The "I" character at the beginning of a line in routing table shows that it is a route discovered by Interior Gateway Routing Protocol (IGRP) and "C" character shows that it is a directly connected network.

 

Verify the Connectivity between Networks Using the Ping Command

To verify the Interior Gateway Routing Protocol (IGRP) routes and the connectivity between networks, run the ping command from Host01 (IP address: 172.16.0.10/16) to Host03 (IP address: 172.20.0.10/16).

C:\>ping 172.20.0.10

Pinging 172.20.0.10 with 32 bytes of data:

Reply from 172.20.0.10: bytes=32 time=172ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125
Reply from 172.20.0.10: bytes=32 time=157ms TTL=125
Reply from 172.20.0.10: bytes=32 time=188ms TTL=125

Ping statistics for 172.20.0.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 157ms, Maximum = 188ms, Average = 176ms

 

The ping reply from Host03 (IP address: 172.20.0.10/16) shows that the Interior Gateway Routing Protocol (IGRP) is configured well in three routers and there is network connectivity between different networks.

---Reference from http://www.omnisecu.com/cisco-certified-network-associate-ccna/how-to-configure-interior-gateway-routing-protocol-igrp.htm

More Related Topics:

Routing Information Protocol & RIP Configuration

How to Configure IGRP (Interior Gateway Routing Protocol)?

Basic Information of Configuring HSRP on a Cisco Router

How to Configure Cisco IP SLA?

What the Main Difference between HSRP, VRRP and GLBP Protocols

Read more

BGP Protocol is Essential in Your IP Network

February 5 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco & Cisco Network

As we known, Border Gateway Protocol (BGP) has the reputation of being the hardest routing protocol to design, configure and maintain. But while this notion has some validity, there are situations where BGP is the only tool available to get the job done, or where deploying BGP throughout your network can increase its security or stability.

 BGP.jpg

BGP's complexity is primarily due to the large number of attributes it can attach to a route, its complex route selection rules, and the manual configuration of neighboring routers (which are discovered automatically in most other routing protocols) needed to ensure the security of the routing information exchange. Having a large number of configuration options and BGP-specific filtering mechanisms available on routers from different major vendors doesn't help either.

 

In this article, we will give you five scenarios where BGP is the best match for your network requirements.

 

Internet Service Advantages

If you're an Internet service provider (ISP), running BGP in your network is almost a must. I've seen consumer-focused ISPs that tried to get around this recommendation and used BGP solely to peer with their upstream ISPs, but they eventually had to bite the bullet and deploy BGP to increase the stability of their network, provide end-to-end quality-of-service or penetrate enterprise markets. Enterprise-focused ISPs have to run BGP from the start to support their multi-homed customers).

 

Layer 3 VPN Services

We've seen a variety of technologies used to implement Layer 3 VPN services in recent years, and MPLS-based VPNs have undoubtedly proven to be the most scalable solution, partly due to using BGP as the underlying routing protocol. Fortunately, you don't have to deploy BGP everywhere in your network if you want to deploy MPLS/VPN solutions. It's enough to deploy BGP on the Provider Edge (PE) routers that connect your VPN customers and on a few core devices that act as route servers (these devices should not be expected to forward heavy traffic loads).

 

Increasing Network Stability

Although we've met networking engineers trying to use BGP as the sole routing protocol in their networks, that's not how you should use it. Any decent BGP design should rely on another faster routing protocol (for example, OSPF, EIGRP or IS-IS) to provide core routing in the network, with BGP responsible for the edge/customer routing.

 

With the separation of core and edge routing into two routing protocols, your network core becomes more stable, as the edge problems cannot disrupt the core. This design has been used very successfully in large enterprise networks with haphazard addressing schemes that defied attempts at route summarization. It should also be used in almost all service provider environments. You should never carry your customers' routes in your core routing protocol, as customer's internal problems could quickly affect the stability of your own network.

 

We must note that it's amazing what you can see in the field. We saw an ISP running OSPF with its customers a few years ago. In that setup, a rogue or ignorant customer could have easily disrupted the whole service provider network.

 

Automatic Response to Denial-of-Service Attacks

Among other peculiarities, BGP allows you to specify any IP address as the next-hop for an IP prefix. This property is most-often used to ensure optimum routing across a BGP autonomous system. You can also use it to implement network-wide sinkholes and remote blackholes to quickly stop worms and denial-of-service attacks on your network.

 

Please note that you don't have to migrate your routing to BGP if you want to use these mechanisms. To implement remote blackholes, it's enough that you deploy BGP on strategic points in your network and link them via BGP sessions with a central router through which you'll insert the IP addresses to block.

 

Large-scale QOS or Web Caching Deployment

Not only does BGP carry a number of attributes describing the IP routes, it allows you to add extra baggage to every IP route it advertises in the form of BGP communities that are totally transparent to BGP (unless you're manually configuring route selection rules to use them) but propagated throughout the network.

 

A few technologies completely unrelated to BGP allow you to use these attributes to implement large-scale designs. For example, Quality-of-Service Policy Propagation with BGP (QPPB) allows you to set QoS bits for specific BGP destinations based on BGP communities and other BGP attributes. Similarly, you can control the Web Cache Communication Protocol (WCCP)-based web caching policy with BGP.

 

So…

Even though BGP is categorized as a complex and hard-to-configure routing protocol, its deployment in large enterprise networks can bring significant benefits, which is almost mandatory in a service provider environment.

 

Note: Introduction to the author: Ivan Pepelnjak, CCIE No. 1354, is a 25-year veteran of the networking industry. He has more than 10 years of experience in designing, installing, troubleshooting and operating large service provider and enterprise WAN and LAN networks and is currently chief technology advisor at NIL Data Communications, focusing on advanced IP-based networks and web technologies. 

---http://searchtelecom.techtarget.com/tip/5-essential-reasons-for-BGP-in-your-IP-network

More Cisco and Network Tips:

BGP Routing Protocol Tips You Need to Know

Routing Information Protocol & RIP Configuration

How to Configure IGRP (Interior Gateway Routing Protocol)?

CCNP SWITCH 642-813 Guide: Configuring IP SLA

How to Use Cisco IP SLA to Manipulate Route Forwarding Decisions?

More Technical Case from Cisco.com:

BGP Case Studies

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml

Read more

IGRP Basic Information

February 2 2013 , Written by Cisco & Cisco Router, Network Switch Published on #Cisco Certification - CCNA - CCNP - CCIE

The Interior Gateway Routing Protocol (IGRP) is a Cisco-proprietary routing protocol for IP

.IGRP-Info.jpg

Some of the features ifInterior Gateway Routing Protocol (IGRP) are

• Interior Gateway Routing Protocol (IGRP) uses a sophisticated metric based on bandwidth and delay.

• Interior Gateway Routing Protocol (IGRP) uses triggered updates to speed-up convergence.

• Interior Gateway Routing Protocol (IGRP) supports unequal-cost load balancing to a single destination.

 

Interior Gateway Routing Protocol (IGRP) uses bandwidth, delay, reliability, load, to find the metric value. By default, the algorithm uses only bandwidth and delay, but the other metric components can be enabled. IGRP uses bandwidth, delay, reliability, load, and MTU to find the metric value. By default, the algorithm uses only bandwidth and delay, but the other metric components can be enabled.

The following formula is used to calculate the composite metric of IGRP.

Metric = [K1 * Bandwidth + (K2 * Bandwidth)/ (256-Load) + K3*Delay] * [K5/(Reliability + K4)]

The default constant values are K1 = K3 = 1 and K2 = K4 = K5 = 0.

If K5 = 0, the [K5/ (reliability + K4)] term is not used. So, given the default values for K1 through K5, the composite metric calculation used by IGRP reduces to Metric = Bandwidth + Delay.

•To find the bandwidth value, find the smallest of all the bandwidths in Kbps from outgoing interfaces anddivide 10,000,000 by that number.

•Reliability and load are measured 1–255. A reliability of 1 is least reliable, while 255 is most reliable. A load of 1 is least utilized, while 255 is 100 percent utilized. The MTU refers to the size of the frame. If a route has lower metric value, then that route is preferred.

•In order to find the delay, add all of the delays (in microseconds) from the outgoing interfaces and divide thisnumber by 10. (The delay is in tenths of microseconds.)

 

More Related Topics:

How to Configure IGRP (Interior Gateway Routing Protocol)?

Routing Information Protocol & RIP Configuration

How to Configure EIGRP on a Cisco Router?

How to Configure OSPF on Cisco Routers?

OSPF, How to Configure OSPF in the Cisco IOS?

How to Configure OSPF in a Single Area?

How to Troubleshoot OSPF?

Read more